Loading...

Forum Index > Discussion > power steering intermittent- Gear box or pump?

nate9871 59 days ago
ActivityRank: 0
Hi,

Occasionally when I'm making a tight turn I suddenly "loose" power steering about halfway through. To restore power I usually have to put the car into reverse and re-adjust the wheel a bit.

It's been doing this for years but is progressively getting worse. Usually happens:
  • at low speeds (under 5MPH) and when parking
  • after making a hard left and then hard right turn (when maneuvering in a parking garage) 
How can I tell if it is my gearbox or pump? 

 
 
     
rajeevx7 59 days ago
ActivityRank: 0
Speed related failure sounds like the vanes in the pump are worn. I would try a pump first. Don’t forget to bleed it well!
nate9871 59 days ago
ActivityRank: 0
Can my current pump (vanes) be rebuilt with a kit or is it better to buy online remanufactured units?

Current pump looks original and would like to fix myself if possible. Any suggestions?
rajeevx7 58 days ago
ActivityRank: 0
Not worth it! Buy a new/used one. 
It’s always something with these cars:-)

Share

Latest Activity

replied to a message on the forum RE: 1966 Fleetwood Series 75 Build.
6 hours ago
replied to a message on the forum RE: 1966 Fleetwood Series 75 Build.
7 hours ago
replied to a message on the forum RE: Loud grinding noise, need help..
5 days ago
replied to a message on the forum RE: Loud grinding noise, need help..
6 days ago
replied to a message on the forum RE: Loud grinding noise, need help..
6 days ago
posted a new message on the forum Loud grinding noise, need help..
7 days ago
replied to a message on the forum RE: Battery ground to engine.
8 days ago
replied to a message on the forum RE: 110 octane fuel?.
9 days ago
replied to a message on the forum RE: Battery ground to engine.
9 days ago
posted a new message on the forum Battery ground to engine.
11 days ago

Top Contributors

1265
"EZ"
750
Scot Minesinger
713
Jeff Burland
477
clsalamo
435
digitalphotoworks